# Self hosted Taiga

**URL:** https://community.taiga.io/c/technical/self-hosted-taiga/11.md?page=1

[Latest](https://community.taiga.io/latest.md) · [Categories](https://community.taiga.io/categories.md) · [Tags](https://community.taiga.io/tags.md)

**Page:** 2

---

## [Create users from the interface — Is it possible?](https://community.taiga.io/t/create-users-from-the-interface-is-it-possible/7146)

<div class="topic-metadata">

**Author:** [@El\_houssine\_Aanan](https://community.taiga.io/u/El_houssine_Aanan)\
**Replies:** 3\
**Last updated:** [April 21, 2025, 12:23pm UTC](https://community.taiga.io/t/create-users-from-the-interface-is-it-possible/7146 "2025-04-21T12:23:07Z")

</div>

Hello, I’ve installed Taiga using Docker and created my superuser account without any issues. However, I can’t find the section in the interface that allows me to create new users. Is it possible to create users direct…

---

## [How to close sprints?](https://community.taiga.io/t/how-to-close-sprints/4138)

<div class="topic-metadata">

**Author:** [@elena1](https://community.taiga.io/u/elena1)\
**Replies:** 3\
**Last updated:** [April 18, 2025, 8:01pm UTC](https://community.taiga.io/t/how-to-close-sprints/4138 "2025-04-18T20:01:39Z")

</div>

It used to be that sprints closed automatically when you finished everything in the sprint. That seems to not work anymore. I made sure all tasks are moved to the done column and even changed to done the user stories the…

---

## [Unable to access Taiga Backend](https://community.taiga.io/t/unable-to-access-taiga-backend/6817)

<div class="topic-metadata">

**Author:** [@azeleuh](https://community.taiga.io/u/azeleuh)\
**Replies:** 5\
**Last updated:** [April 1, 2025, 5:30am UTC](https://community.taiga.io/t/unable-to-access-taiga-backend/6817 "2025-04-01T05:30:30Z")

</div>

Hi, i’m currently setting up a Self Hosted Taiga server from source code. I followed the instructions in the documentation, but at the backend verification step, i’m not able to connect to anything related to the taiga …

---

## [CSS failing to load on subpath configuration](https://community.taiga.io/t/css-failing-to-load-on-subpath-configuration/6891)

<div class="topic-metadata">

**Author:** [@Sean](https://community.taiga.io/u/Sean)\
**Replies:** 0\
**Last updated:** [March 29, 2025, 10:15am UTC](https://community.taiga.io/t/css-failing-to-load-on-subpath-configuration/6891 "2025-03-29T10:15:13Z")

</div>

I installed Taiga on my ubuntu server following the steps outlined in the README file on github. I wanted to configure it to be a subpath on a site I host on the same server using NGINX as a webserver. After following t…

---

## [WebSocket issues and slow interface on self-hosted Taiga instance (Docker)](https://community.taiga.io/t/websocket-issues-and-slow-interface-on-self-hosted-taiga-instance-docker/6854)

<div class="topic-metadata">

**Author:** [@glazole](https://community.taiga.io/u/glazole)\
**Replies:** 0\
**Last updated:** [March 27, 2025, 1:47pm UTC](https://community.taiga.io/t/websocket-issues-and-slow-interface-on-self-hosted-taiga-instance-docker/6854 "2025-03-27T13:47:39Z")

</div>

Hi Taiga Team, I’m running a self-hosted Taiga instance using Docker, and I’m encountering two persistent problems: :turtle: 1. Very slow UI and page navigation The interface often becomes unresponsive. Switching betw…

---

## [OIDC Authentication for Taiga API not working (Keycloak + robrotheram/taiga-back-openid)](https://community.taiga.io/t/oidc-authentication-for-taiga-api-not-working-keycloak-robrotheram-taiga-back-openid/6853)

<div class="topic-metadata">

**Author:** [@glazole](https://community.taiga.io/u/glazole)\
**Replies:** 0\
**Last updated:** [March 27, 2025, 1:29pm UTC](https://community.taiga.io/t/oidc-authentication-for-taiga-api-not-working-keycloak-robrotheram-taiga-back-openid/6853 "2025-03-27T13:29:52Z")

</div>

Hi again, In addition to the UI and WebSocket issues, I’m also trying to set up OIDC authentication for the Taiga API using Keycloak as the identity provider. :brick: Setup Taiga is running in Docker using the image: r…

---

## [ModuleNotFoundError: No module named 'distutils'](https://community.taiga.io/t/modulenotfounderror-no-module-named-distutils/6844)

<div class="topic-metadata">

**Author:** [@zarir-engineer](https://community.taiga.io/u/zarir-engineer)\
**Replies:** 1\
**Last updated:** [March 27, 2025, 9:40am UTC](https://community.taiga.io/t/modulenotfounderror-no-module-named-distutils/6844 "2025-03-27T09:40:05Z")

</div>

I have forked taiga-back and using its stable branch. repo : GitHub - zarir-engineer/taiga-back In the dockerfile the first line is FROM python:3.11-slim in contrast the control is going thru python 3.12 as the erro…

---

## [Facing issue to Taiga Setup with Gitlab OAuth login](https://community.taiga.io/t/facing-issue-to-taiga-setup-with-gitlab-oauth-login/6582)

<div class="topic-metadata">

**Author:** [@neel.oza1](https://community.taiga.io/u/neel.oza1)\
**Replies:** 3\
**Last updated:** [March 24, 2025, 9:21am UTC](https://community.taiga.io/t/facing-issue-to-taiga-setup-with-gitlab-oauth-login/6582 "2025-03-24T09:21:45Z")

</div>

Hello, We are planning to use Taiga self hosting solution for our organization. We are already using GitLab self hosting solution running on hxxps://gitlab.domain.com. We could host Taiga using Taiga 30min Setup and it…

---

## [WebSocket error: \[object Event\]](https://community.taiga.io/t/websocket-error-object-event/5317)

<div class="topic-metadata">

**Author:** [@BB\_Ead](https://community.taiga.io/u/BB_Ead)\
**Replies:** 2\
**Last updated:** [March 10, 2025, 7:45am UTC](https://community.taiga.io/t/websocket-error-object-event/5317 "2025-03-10T07:45:01Z")

</div>

Hello :slight\_smile: I have set up an environment on an Ubuntu server via a subdomain following the “Taiga 30min Setup”. The proxy host and SSL certificate are set up via “Nginx Proxy Manager”. (taiga.domain. com → htt…

---

## [Challenge faced during self hosting Taiga](https://community.taiga.io/t/challenge-faced-during-self-hosting-taiga/5998)

<div class="topic-metadata">

**Author:** [@sathyaguru](https://community.taiga.io/u/sathyaguru)\
**Replies:** 3\
**Last updated:** [March 8, 2025, 1:48pm UTC](https://community.taiga.io/t/challenge-faced-during-self-hosting-taiga/5998 "2025-03-08T13:48:02Z")

</div>

Hi team, we tried to self-host Taiga but facing issue while creating a project. Actually, we hosted in our IP but after that while trying to create a new project it is loading and nothing happens after that. While checki…

---

## [New Taiga, reverse proxying with HTTPS using Caddy](https://community.taiga.io/t/new-taiga-reverse-proxying-with-https-using-caddy/5615)

<div class="topic-metadata">

**Author:** [@NickyDoes](https://community.taiga.io/u/NickyDoes)\
**Replies:** 2\
**Last updated:** [March 8, 2025, 3:55am UTC](https://community.taiga.io/t/new-taiga-reverse-proxying-with-https-using-caddy/5615 "2025-03-08T03:55:59Z")

</div>

Hello all, Another proxy help request. Seems we need a tag for these. I’ve read the others, but it still looks like the Matrix to me. I have Taiga Docker installed, and I’m intending to access as https://projects.exa…

---

## [User locked out](https://community.taiga.io/t/user-locked-out/2968)

<div class="topic-metadata">

**Author:** [@anon21515651](https://community.taiga.io/u/anon21515651)\
**Replies:** 3\
**Last updated:** [April 1, 2024, 3:08pm UTC](https://community.taiga.io/t/user-locked-out/2968 "2024-04-01T15:08:43Z")

</div>

Hi, this is my first post to the community and I am really hoping someone will be able to help with this issue. I am our Taiga admin. I did not set any of it up; I inherited it. However, I have added and removed users…

---

## [How change taiga default logo](https://community.taiga.io/t/how-change-taiga-default-logo/5287)

<div class="topic-metadata">

**Author:** [@Dattu\_Prabhakararao](https://community.taiga.io/u/Dattu_Prabhakararao)\
**Replies:** 1\
**Last updated:** [February 16, 2025, 7:29am UTC](https://community.taiga.io/t/how-change-taiga-default-logo/5287 "2025-02-16T07:29:52Z")

</div>

When i was trying to change deafult logo how to change the default logo

---

## [Redirect discover page to login page](https://community.taiga.io/t/redirect-discover-page-to-login-page/5291)

<div class="topic-metadata">

**Author:** [@khormine](https://community.taiga.io/u/khormine)\
**Replies:** 1\
**Last updated:** [February 16, 2025, 12:10am UTC](https://community.taiga.io/t/redirect-discover-page-to-login-page/5291 "2025-02-16T00:10:44Z")

</div>

Hi ! I’m looking for a way to restrict unauthenticated users access by showing them only the /login page. I know that by default, unauthenticated users have access to the /discover page. Therefore, I want to redirect the…

---

## [Console error log user-storage 404](https://community.taiga.io/t/console-error-log-user-storage-404/5231)

<div class="topic-metadata">

**Author:** [@Szymon\_Marciniak](https://community.taiga.io/u/Szymon_Marciniak)\
**Replies:** 0\
**Last updated:** [February 11, 2025, 9:41am UTC](https://community.taiga.io/t/console-error-log-user-storage-404/5231 "2025-02-11T09:41:34Z")

</div>

I managed to put up and configure taiga on ubuntu server, everything works, but when I go to Scrum or Kanban I get these errors in the browser console Request URL: http://192.168.13.153:9001/api/v1/user-storage/0f075c1…

---

## [Microsoft smtp server setup](https://community.taiga.io/t/microsoft-smtp-server-setup/4996)

<div class="topic-metadata">

**Author:** [@Avenash\_Sharma](https://community.taiga.io/u/Avenash_Sharma)\
**Replies:** 0\
**Last updated:** [January 28, 2025, 9:13am UTC](https://community.taiga.io/t/microsoft-smtp-server-setup/4996 "2025-01-28T09:13:20Z")

</div>

i have self hosted taiga management on my server i have configured the smtp environment for sending mails but when i try to send the mail from the server it shows me this error logs i have configured the smtp environment…

---

## [Is it possible to transfer whole project into another one?](https://community.taiga.io/t/is-it-possible-to-transfer-whole-project-into-another-one/4842)

<div class="topic-metadata">

**Author:** [@Madog](https://community.taiga.io/u/Madog)\
**Replies:** 3\
**Last updated:** [February 7, 2025, 7:35am UTC](https://community.taiga.io/t/is-it-possible-to-transfer-whole-project-into-another-one/4842 "2025-02-07T07:35:33Z")

</div>

I’ve got project with lot’s of data inside (epics, tasks). Can I duplicate it somehow into another project, with exact same settings and tasks etc? I would just clean it and re-open everything I need.

---

## [Auto Saving of custom attributes](https://community.taiga.io/t/auto-saving-of-custom-attributes/5145)

<div class="topic-metadata">

**Author:** [@Divyam\_Khandelwal](https://community.taiga.io/u/Divyam_Khandelwal)\
**Replies:** 0\
**Last updated:** [February 6, 2025, 7:47am UTC](https://community.taiga.io/t/auto-saving-of-custom-attributes/5145 "2025-02-06T07:47:52Z")

</div>

Hi , I have added 4-5 custom fields in story , facing issues Auto saving is not there or i am missing something ?? So i want whenever user enter text in textfield it should be saved, instead of clicking on save butto…

---

## [Webhooks not work for self hosted Taiga (docker)](https://community.taiga.io/t/webhooks-not-work-for-self-hosted-taiga-docker/5011)

<div class="topic-metadata">

**Author:** [@Alexej\_Demov](https://community.taiga.io/u/Alexej_Demov)\
**Replies:** 1\
**Last updated:** [February 5, 2025, 9:29am UTC](https://community.taiga.io/t/webhooks-not-work-for-self-hosted-taiga-docker/5011 "2025-02-05T09:29:04Z")

</div>

I have set up a Webhook. I have checked the Webhook with a test button in Taiga - everything works. But when I do tasks in the project I do not receive notifications. What should I do and where should I look to fix it…

---

## [Configuring authorization via Keycloak](https://community.taiga.io/t/configuring-authorization-via-keycloak/4923)

<div class="topic-metadata">

**Author:** [@glazole](https://community.taiga.io/u/glazole)\
**Replies:** 3\
**Last updated:** [January 27, 2025, 7:47pm UTC](https://community.taiga.io/t/configuring-authorization-via-keycloak/4923 "2025-01-27T19:47:05Z")

</div>

Dear friends. Configuring authorization via Keycloak. I have installed the plugin, the redirect is working, but something is not going through to the end. After entering the username and password, it returns to Taiga bu…

---

## [I cannot (re)create superuser and i cannot login after install](https://community.taiga.io/t/i-cannot-re-create-superuser-and-i-cannot-login-after-install/4983)

<div class="topic-metadata">

**Author:** [@Hans\_Somers](https://community.taiga.io/u/Hans_Somers)\
**Replies:** 1\
**Last updated:** [January 27, 2025, 11:42am UTC](https://community.taiga.io/t/i-cannot-re-create-superuser-and-i-cannot-login-after-install/4983 "2025-01-27T11:42:31Z")

</div>

After cloning the taiga repo i want to create the superuser, using sudo ./taiga-manage.sh createsuperuser I get the error: django.db.utils.OperationalError: connection to server at “taiga-db” (172.19.0.4), port 5432 f…

---

## [Lost Project Owner](https://community.taiga.io/t/lost-project-owner/4557)

<div class="topic-metadata">

**Author:** [@matchip03](https://community.taiga.io/u/matchip03)\
**Replies:** 2\
**Last updated:** [January 21, 2025, 5:25am UTC](https://community.taiga.io/t/lost-project-owner/4557 "2025-01-21T05:25:05Z")

</div>

Hi, I accidentally deleted participants in my project, and after a few months, I realized that participants actually created that project. So I have a problem adding any participants because that project now has no proj…

---

## [Docker taiga 6.8.0 / docker network](https://community.taiga.io/t/docker-taiga-6-8-0-docker-network/4885)

<div class="topic-metadata">

**Author:** [@herf](https://community.taiga.io/u/herf)\
**Replies:** 0\
**Last updated:** [January 15, 2025, 2:45pm UTC](https://community.taiga.io/t/docker-taiga-6-8-0-docker-network/4885 "2025-01-15T14:45:12Z")

</div>

Hi, I install a taiga container docker, but I want absolutely change the network. The docker container has always a network, which looks like the host subnet. As other containers are in 172.xx, and I have no problem, …

---

## [Taiga is down. Events are disabled](https://community.taiga.io/t/taiga-is-down-events-are-disabled/4676)

<div class="topic-metadata">

**Author:** [@csmu](https://community.taiga.io/u/csmu)\
**Replies:** 11\
**Last updated:** [January 14, 2025, 8:29am UTC](https://community.taiga.io/t/taiga-is-down-events-are-disabled/4676 "2025-01-14T08:29:31Z")

</div>

Any ideas on how to resolve the following? Events are disabled: the maximum number of connection errors has been reached. I brought down the services with docker compose -f docker-compose.yml down then I brought them…

---

## [Taiga setup using docker - admin panel not rendering properly](https://community.taiga.io/t/taiga-setup-using-docker-admin-panel-not-rendering-properly/3313)

<div class="topic-metadata">

**Author:** [@dgadiraju](https://community.taiga.io/u/dgadiraju)\
**Replies:** 5\
**Last updated:** [January 13, 2025, 2:13pm UTC](https://community.taiga.io/t/taiga-setup-using-docker-admin-panel-not-rendering-properly/3313 "2025-01-13T14:13:33Z")

</div>

I have setup taiga on a bare metal server using docker. Every thing seems to be working fine, except https://taiga.itversity.com/admin. The page is rendering without proper css and javascript.

---

## [How to adjust the 'Blocker' CSS (or any other CSS) with as little effort as possible, when using Docker](https://community.taiga.io/t/how-to-adjust-the-blocker-css-or-any-other-css-with-as-little-effort-as-possible-when-using-docker/4806)

<div class="topic-metadata">

**Author:** [@mig5](https://community.taiga.io/u/mig5)\
**Replies:** 1\
**Last updated:** [January 6, 2025, 2:35am UTC](https://community.taiga.io/t/how-to-adjust-the-blocker-css-or-any-other-css-with-as-little-effort-as-possible-when-using-docker/4806 "2025-01-06T02:35:51Z")

</div>

Hi, I set a blocker on a story with a URL as the text. As you can see in the screenshot, it’s a bit hard to read the link text. How do I customise the theme to change either the background or the text colour? I be…

---

## [Taiga-okta authentication using SAML plugin gets 405 error](https://community.taiga.io/t/taiga-okta-authentication-using-saml-plugin-gets-405-error/4384)

<div class="topic-metadata">

**Author:** [@mouse321](https://community.taiga.io/u/mouse321)\
**Replies:** 3\
**Last updated:** [December 20, 2024, 6:24pm UTC](https://community.taiga.io/t/taiga-okta-authentication-using-saml-plugin-gets-405-error/4384 "2024-12-20T18:24:54Z")

</div>

Hi, I have a taiga server installed using source code. I managed to get the saml-auth-contrib plugin to work for okta. So when i press “sign in with saml”, i get redirected to our okta sign in. i get authenticated fine (…

---

## [Enabling SSL with Custom Certificates on Self-Hosted Tiaga using Docker](https://community.taiga.io/t/enabling-ssl-with-custom-certificates-on-self-hosted-tiaga-using-docker/4703)

<div class="topic-metadata">

**Author:** [@Sandeep\_Reddy](https://community.taiga.io/u/Sandeep_Reddy)\
**Replies:** 1\
**Last updated:** [December 16, 2024, 10:32am UTC](https://community.taiga.io/t/enabling-ssl-with-custom-certificates-on-self-hosted-tiaga-using-docker/4703 "2024-12-16T10:32:06Z")

</div>

Hi Tiaga Community, I’m currently running a self-hosted Tiaga instance using Docker and would like to enable SSL using my own certificates. Could anyone guide me through the process or provide the required steps for con…

---

## [Taiga Mailsetup with O365](https://community.taiga.io/t/taiga-mailsetup-with-o365/4684)

<div class="topic-metadata">

**Author:** [@tcs](https://community.taiga.io/u/tcs)\
**Replies:** 0\
**Last updated:** [December 13, 2024, 12:38pm UTC](https://community.taiga.io/t/taiga-mailsetup-with-o365/4684 "2024-12-13T12:38:09Z")

</div>

Hello, I just successfully set up a docker installation of Taiga, thank you very much for the phantastic project and the documentation. Since we use O365/M365 SMTP won’t be an option for long. Is there a possibility to…

---

## [Taiga without events](https://community.taiga.io/t/taiga-without-events/4680)

<div class="topic-metadata">

**Author:** [@csmu](https://community.taiga.io/u/csmu)\
**Replies:** 0\
**Last updated:** [December 12, 2024, 11:08pm UTC](https://community.taiga.io/t/taiga-without-events/4680 "2024-12-12T23:08:45Z")

</div>

What would need to be changed in docker-taiga.yml to enable taiga to run without events?

[Previous page](https://community.taiga.io/c/technical/self-hosted-taiga/11.md)

[Next page](https://community.taiga.io/c/technical/self-hosted-taiga/11.md?page=2)
