# Error in frontend: Something happened and the Taiga has captured

**URL:** <https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184>\
**Category:** Self hosted Taiga\
**Created:** [April 24, 2024, 12:26pm UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184 "2024-04-24T12:26:08Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pedro\_Sanchez\_Roca](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/pedro_sanchez_roca/32/1461_2.png) [@Pedro\_Sanchez\_Roca](https://community.taiga.io/u/Pedro_Sanchez_Roca)\
**Post date:** [April 24, 2024, 12:26pm UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/1 "2024-04-24T12:26:08Z")

</div>

**Installed Taiga using Docker in a Windows 10 machine.**

All working fine on current machine, changed .env file TAIGA\_DOMAIN=xxx.xxx.xxx.xxx:9000 to reflect the IP of the host machine.

Taiga is reachable from browser in host machine.

When trying to access Taiga at xxx.xxx.xxx.xxx:9000 from another machine in the same network, I get error in frontend

`Something happened and the Taiga has captured the error to be able to work on it.`

 ![image](https://europe1.discourse-cdn.com/flex017/uploads/taiga/original/2X/5/52586116e1f3585f3795dbd445a2cc07d3e872ab.jpeg)

---

<div class="post-metadata">

**Author:** ![shakhawat1355](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/shakhawat1355/32/2260_2.png) [@shakhawat1355](https://community.taiga.io/u/shakhawat1355)\
**Post date:** [April 24, 2024, 3:04pm UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/2 "2024-04-24T15:04:24Z")

</div>

can you share your nginx config?

---

<div class="post-metadata">

**Author:** ![Pedro\_Sanchez\_Roca](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/pedro_sanchez_roca/32/1461_2.png) [@Pedro\_Sanchez\_Roca](https://community.taiga.io/u/Pedro_Sanchez_Roca)\
**Post date:** [April 25, 2024, 4:34am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/3 "2024-04-25T04:34:07Z")

</div>

Sure, and thanks for your answer.

Is it on the taiga.conf file?. I have not really touched anything on that file, looks like this:

```auto
server {
    listen 80 default_server;

    client_max_body_size 100M;
    charset utf-8;

    # Frontend
    location / {
        proxy_pass http://taiga-front/;
        proxy_pass_header Server;
        proxy_set_header Host $http_host;
        proxy_redirect off;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Scheme $scheme;
    }

    # API
    location /api/ {
        proxy_pass http://taiga-back:8000/api/;
        proxy_pass_header Server;
        proxy_set_header Host $http_host;
        proxy_redirect off;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Scheme $scheme;
    }

    # Admin
    location /admin/ {
        proxy_pass http://taiga-back:8000/admin/;
        proxy_pass_header Server;
        proxy_set_header Host $http_host;
        proxy_redirect off;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Scheme $scheme;
    }

    # Static
    location /static/ {
        alias /taiga/static/;
    }

    # Media
    location /_protected/ {
        internal;
        alias /taiga/media/;
        add_header Content-disposition "attachment";
    }

    # Unprotected section
    location /media/exports/ {
        alias /taiga/media/exports/;
        add_header Content-disposition "attachment";
    }

    location /media/ {
        proxy_set_header Host $http_host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Scheme $scheme;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass http://taiga-protected:8003/;
        proxy_redirect off;
    }

    # Events
    location /events {
        proxy_pass http://taiga-events:8888/events;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_connect_timeout 7d;
        proxy_send_timeout 7d;
        proxy_read_timeout 7d;
    }
}

```

---

<div class="post-metadata">

**Author:** ![Charlie](https://avatars.discourse-cdn.com/v4/letter/c/d6d6ee/32.png) [@Charlie](https://community.taiga.io/u/Charlie)\
**Post date:** [April 25, 2024, 6:57am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/4 "2024-04-25T06:57:59Z")

</div>

Hi there!

The error happens because, for the domain, you used localhost instead of the LAN IP Address.

If you connect from another machine, then your browser will search for the API endpoint and the websocket endpoint on localhost.

Hope this clarifies it!

Best regards!

---

<div class="post-metadata">

**Author:** ![Pedro\_Sanchez\_Roca](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/pedro_sanchez_roca/32/1461_2.png) [@Pedro\_Sanchez\_Roca](https://community.taiga.io/u/Pedro_Sanchez_Roca)\
**Post date:** [April 25, 2024, 7:00am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/5 "2024-04-25T07:00:55Z")

</div>

> [@Pedro\_Sanchez\_Roca](#):
>
> All working fine on current machine, changed .env file TAIGA\_DOMAIN=xxx.xxx.xxx.xxx:9000 to reflect the IP of the host machine.

Hi Charlie thanks for your answer, but I am not sure if I follow you. I mentioned in my post the above mentioned.

Maybe I am wrong?.

---

<div class="post-metadata">

**Author:** ![Charlie](https://avatars.discourse-cdn.com/v4/letter/c/d6d6ee/32.png) [@Charlie](https://community.taiga.io/u/Charlie)\
**Post date:** [April 25, 2024, 7:03am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/6 "2024-04-25T07:03:13Z")

</div>

Did you recreate the containers afterwards?

Because your dev tools show that it is trying to connect to localhost, that’s why I mentioned localhost.

It should be enough to do `docker-compose up -d` if you are using the docker-compose method.

Regards!

---

<div class="post-metadata">

**Author:** ![Pedro\_Sanchez\_Roca](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/pedro_sanchez_roca/32/1461_2.png) [@Pedro\_Sanchez\_Roca](https://community.taiga.io/u/Pedro_Sanchez_Roca)\
**Post date:** [April 25, 2024, 7:31am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/7 "2024-04-25T07:31:17Z")

</div>

even after recreate, still same error, I can also get conf.json file at xxx.xxx.xxx.xxx:9000/conf.json and shows this:

```auto
{
    "api": "http://localhost:9000/api/v1/",
    "eventsUrl": "ws://localhost:9000/events",
    "baseHref": "/",
    "eventsMaxMissedHeartbeats": 5,
    "eventsHeartbeatIntervalTime": 60000,
    "eventsReconnectTryInterval": 10000,
    "debug": false,
    "debugInfo": false,
    "defaultLanguage": "en",
    "themes": ["taiga"],
    "defaultTheme": "taiga",
    "defaultLoginEnabled": true,
    "publicRegisterEnabled": false,
    "feedbackEnabled": true,
    "supportUrl": "https://community.taiga.io/",
    "privacyPolicyUrl": null,
    "termsOfServiceUrl": null,
    "maxUploadFileSize": null,
    "contribPlugins": [],
    "gitHubClientId": "",
    "gitLabClientId": "",
    "gitLabUrl": "",
    "tagManager": { "accountId": null },
    "tribeHost": null,
    "enableAsanaImporter": false,
    "enableGithubImporter": false,
    "enableJiraImporter": false,
    "enableTrelloImporter": false,
    "gravatar": false,
    "rtlLanguages": [
        "ar",
        "fa",
        "he"
    ]
}

```

Should I manually modify conf.json to remove “localhost”? how to access it?

---

<div class="post-metadata">

**Author:** ![david.barragan](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/david.barragan/32/293_2.png) [@david.barragan](https://community.taiga.io/u/david.barragan)\
**Post date:** [April 25, 2024, 7:40am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/8 "2024-04-25T07:40:26Z")

</div>

Hi @Pedro_Sanchez_Roca dro,

You just should to follow [30 min setup guide](https://community.taiga.io/t/taiga-30min-setup/170#urls-settings-8) and change `TAIGA_DOMAIN` with the correct value. Then, you have to restart the services.

Best regards

---

<div class="post-metadata">

**Author:** ![Pedro\_Sanchez\_Roca](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/pedro_sanchez_roca/32/1461_2.png) [@Pedro\_Sanchez\_Roca](https://community.taiga.io/u/Pedro_Sanchez_Roca)\
**Post date:** [April 25, 2024, 7:42am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/9 "2024-04-25T07:42:02Z")

</div>

Thanks David, already done that. TAIGA\_DOMAIN is at the correct value, superuser created, restart service, etc.

Works in host machine Just not accessible from other machines.

---

<div class="post-metadata">

**Author:** ![david.barragan](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/david.barragan/32/293_2.png) [@david.barragan](https://community.taiga.io/u/david.barragan)\
**Post date:** [April 25, 2024, 8:11am UTC](https://community.taiga.io/t/error-in-frontend-something-happened-and-the-taiga-has-captured/3184/10 "2024-04-25T08:11:48Z")

</div>

Try to force to remove the containers of the services to apply the new change.

```auto
docker compose rm taiga-front taiga-back taiga-async taiga-async-rabbitmq taiga-protected taiga-events taiga-events-rabbitmq

```

And start again taiga to recreate the container again.
