# OIDC(Keycloak) ERROR: After clicking login, I cannot enter, but the keycloak session is already connected

**URL:** https://community.taiga.io/t/oidc-keycloak-error-after-clicking-login-i-cannot-enter-but-the-keycloak-session-is-already-connected/8604
**Category:** Self hosted Taiga
**Created:** [November 18, 2025, 9:34am UTC](https://community.taiga.io/t/oidc-keycloak-error-after-clicking-login-i-cannot-enter-but-the-keycloak-session-is-already-connected/8604 "2025-11-18T09:34:39Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![zinc\_nan](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/zinc_nan/32/5422_2.png) [@zinc\_nan](https://community.taiga.io/u/zinc_nan)
#### Post date: [November 18, 2025, 9:34am UTC](https://community.taiga.io/t/oidc-keycloak-error-after-clicking-login-i-cannot-enter-but-the-keycloak-session-is-already-connected/8604/1 "2025-11-18T09:34:39Z")

</div>

![image](https://europe1.discourse-cdn.com/flex017/uploads/taiga/original/2X/b/bb5a906005cd4abb7946e4503c0aaa3e2bba74f1.png)  
As shown in the figure, if you continue to log in using OIDC, it will still prompt an error.  
hear is my front conf.json  
` {`  
` "api": "http://172.16.168.122:9090/api/v1/",`  
` "eventsUrl": "ws://172.16.168.122:9090/events",`  
` "baseHref": "/",`  
` "eventsMaxMissedHeartbeats": 5,`  
` "eventsHeartbeatIntervalTime": 60000,`  
` "eventsReconnectTryInterval": 10000,`  
` "debug": false,`  
` "debugInfo": false,`  
` "defaultLanguage": "en",`  
` "themes": ["taiga"],`  
` "defaultTheme": "taiga",`  
` "defaultLoginEnabled": true,`  
` "publicRegisterEnabled": false,`  
` "feedbackEnabled": true,`  
` "supportUrl": "https://community.taiga.io/",`  
` "privacyPolicyUrl": null,`  
` "termsOfServiceUrl": null,`  
` "maxUploadFileSize": null,`  
` "contribPlugins": ["/plugins/oidc-auth/oidc-auth.json"],`  
` "gitHubClientId": "",`  
` "gitLabClientId": "",`  
` "gitLabUrl": "",`  
` "tagManager": { "accountId": null },`  
` "tribeHost": null,`  
` "enableAsanaImporter": false,`  
` "enableGithubImporter": false,`  
` "enableJiraImporter": false,`  
` "enableTrelloImporter": false,`  
` "gravatar": false,`  
` "rtlLanguages": [`  
` "ar",`  
` "fa",`  
` "he"`  
` ]`  
`}`

I checked other people’s posts and verified that my JSON format is correct.

At first, I set all the mount points to the format of /api/oidc and encountered this error. Now I no longer use the /api prefix; instead, I set up Nginx to directly forward /oidc requests, but the error still exists exactly the same.

When I click the login button, it redirects to the Keycloak login page. I enter my account and password and click login, then the error shown in Figure 1 appears. However, my Keycloak backend shows that the session is already connected, so the error should be occurring in Taiga.

Has anyone encountered a similar issue? Thank you for your help.

---

<div class="post-metadata">

### Author: ![zinc\_nan](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/zinc_nan/32/5422_2.png) [@zinc\_nan](https://community.taiga.io/u/zinc_nan)
#### Post date: [November 20, 2025, 1:37am UTC](https://community.taiga.io/t/oidc-keycloak-error-after-clicking-login-i-cannot-enter-but-the-keycloak-session-is-already-connected/8604/2 "2025-11-20T01:37:33Z")

</div>

The problem is solved. I switched the OIDC plugin from [GitHub - taigaio/taiga-contrib-oidc-auth: OIDC plugin for taiga authentication](https://github.com/taigaio/taiga-contrib-oidc-auth) to [GitHub - robrotheram/taiga-contrib-openid-auth: Taiga plugin for openid authentication](https://github.com/robrotheram/taiga-contrib-openid-auth) . And use the front-end and back-end images with tag:6.5.1 from dockerhub.
