# Taiga docker compose behind trafik reverse proxy into nginx taiga-gateway bad gateway error

**URL:** <https://community.taiga.io/t/taiga-docker-compose-behind-trafik-reverse-proxy-into-nginx-taiga-gateway-bad-gateway-error/2990>\
**Category:** Troubleshooting\
**Tags:** docker\
**Created:** [April 1, 2024, 4:59am UTC](https://community.taiga.io/t/taiga-docker-compose-behind-trafik-reverse-proxy-into-nginx-taiga-gateway-bad-gateway-error/2990 "2024-04-01T04:59:46Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rob](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/rob/32/2357_2.png) [@Rob](https://community.taiga.io/u/Rob)\
**Post date:** [April 1, 2024, 4:59am UTC](https://community.taiga.io/t/taiga-docker-compose-behind-trafik-reverse-proxy-into-nginx-taiga-gateway-bad-gateway-error/2990/1 "2024-04-01T04:59:46Z")

</div>

Hi, I am trying to run Taiga docker compose behind trafik reverse proxy into nginx taiga-gateway but get a 502 bad gateway error. All the containers are running. I am using postgresql from a different container and taiga has populated the db. I uses tiaga-manage.sh to createsuperuser without problems.

Traefik is setup via these labels on the taiga-gateway container in docker compose and the nginx config is the default one from this guide: [Install Taiga in Production](https://docs.taiga.io/setup-production.html)

```auto
  taiga-gateway:
    image: nginx:1.19-alpine
    restart: ${RESTART}
    volumes:
      - /etc/localtime:/etc/localtime:ro
      - /etc/timezone:/etc/timezone:ro
      - $DOCKERDIR/${COMPOSE_PROJECT_NAME}/data/taiga-gateway/taiga.conf:/etc/nginx/conf.d/default.conf
      - $DOCKERDIR/${COMPOSE_PROJECT_NAME}/data/taiga-back/static:/taiga/static
      - $DOCKERDIR/${COMPOSE_PROJECT_NAME}/data/taiga-back/media:/taiga/media
    networks:
      - taiga
      - proxy
    depends_on:
      - taiga-front
      - taiga-back
      - taiga-events
    labels:
      - "traefik.enable=true"
      - "traefik.http.routers.taiga.entrypoints=https"
      - "traefik.http.routers.taiga.rule=Host(`taiga.<real.domain.name>`)"
      - "traefik.http.middlewares.taiga-https-redirect.redirectscheme.scheme=https"
      #
      - "traefik.http.routers.taiga.middlewares=taiga-https-redirect"
      #
      - "traefik.http.routers.taiga.tls=true"
      - "traefik.http.routers.taiga.middlewares=chain-authelia@file"
      - "traefik.http.services.taiga.loadbalancer.server.port=9000"
      - "traefik.docker.network=proxy"

```

---

<div class="post-metadata">

**Author:** ![Rob](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/rob/32/2357_2.png) [@Rob](https://community.taiga.io/u/Rob)\
**Post date:** [April 2, 2024, 7:33am UTC](https://community.taiga.io/t/taiga-docker-compose-behind-trafik-reverse-proxy-into-nginx-taiga-gateway-bad-gateway-error/2990/3 "2024-04-02T07:33:19Z")

</div>

Ok, changing the load balancer port in Traefik to 80 instead of 9000 gives me a blank page, but viewing the source shows it is getting somewhere, and I can get to mytaiga.example/admin and login as the super user I created. PRogress. I will start a new topic and call this one resolved.

---

<div class="post-metadata">

**Author:** ![therealbons](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/therealbons/32/3842_2.png) [@therealbons](https://community.taiga.io/u/therealbons)\
**Post date:** [February 24, 2025, 5:23pm UTC](https://community.taiga.io/t/taiga-docker-compose-behind-trafik-reverse-proxy-into-nginx-taiga-gateway-bad-gateway-error/2990/4 "2025-02-24T17:23:43Z")

</div>

Did you find a solution for the blank page?

---

<div class="post-metadata">

**Author:** ![therealbons](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/therealbons/32/3842_2.png) [@therealbons](https://community.taiga.io/u/therealbons)\
**Post date:** [February 24, 2025, 5:35pm UTC](https://community.taiga.io/t/taiga-docker-compose-behind-trafik-reverse-proxy-into-nginx-taiga-gateway-bad-gateway-error/2990/5 "2025-02-24T17:35:54Z")

</div>

Nevermind, found the solution

---

<div class="post-metadata">

**Author:** ![alh](https://avatars.discourse-cdn.com/v4/letter/a/6a8cbe/32.png) [@alh](https://community.taiga.io/u/alh)\
**Post date:** [May 25, 2025, 7:50am UTC](https://community.taiga.io/t/taiga-docker-compose-behind-trafik-reverse-proxy-into-nginx-taiga-gateway-bad-gateway-error/2990/6 "2025-05-25T07:50:28Z")

</div>

Hello,

Would you mind sharing your working configuration? After hours of trial and error, I still don’t have a functional solution. I’ve only managed to gain access over HTTP, but then the `/admin` doesn’t work. When I do get access to the `/admin`, the CSS fails to load, and the main page isn’t working. It’s very frustrating.

Thanks in advance for any help!
