# Taiga front end not loading

**URL:** <https://community.taiga.io/t/taiga-front-end-not-loading/3827>\
**Category:** Troubleshooting\
**Created:** [August 15, 2024, 6:39am UTC](https://community.taiga.io/t/taiga-front-end-not-loading/3827 "2024-08-15T06:39:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![blackice](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/blackice/32/2861_2.png) [@blackice](https://community.taiga.io/u/blackice)\
**Post date:** [August 15, 2024, 6:39am UTC](https://community.taiga.io/t/taiga-front-end-not-loading/3827/1 "2024-08-15T06:39:34Z")

</div>

This is kind of a weird one. I have a relatively new Taiga install (self-hosted, docker), and something has gone wrong with the front end. In the console I get the following two errors:

Loading failed for the with source “[http://example.com/v-1631701833072/js/libs.js”](http://example.com/v-1631701833072/js/libs.js%E2%80%9D). (obviously that’s not the actual domain where Taiga is installed - I have redacted it)

Uncaught ReferenceError: s is not defined  
onerror [http://example.com/v-1631701833072/js/app-loader.js:1](http://example.com/v-1631701833072/js/app-loader.js:1)

Looking at the logs, I see this warning in taiga-gateway-1, which is obviously related: 2024/08/15 06:34:02 [warn] 31#31: \*54 an upstream response is buffered to a temporary file /var/cache/nginx/proxy\_temp/2/00/0000000002 while reading upstream, client: 172.18.0.1, server: , request: “GET /v-1631701833072/js/libs.js HTTP/1.0”

I have tried restarting the docker containers, but that hasn’t helped.

Has anyone else had this problem before? Any suggestions for fixing it?

---

<div class="post-metadata">

**Author:** ![blackice](https://dub1.discourse-cdn.com/flex017/user_avatar/community.taiga.io/blackice/32/2861_2.png) [@blackice](https://community.taiga.io/u/blackice)\
**Post date:** [August 15, 2024, 11:46pm UTC](https://community.taiga.io/t/taiga-front-end-not-loading/3827/2 "2024-08-15T23:46:41Z")

</div>

Turns out this wasn’t a problem with anything in the docker containers, it was with nginx on the server itself. More investigation showed that I was getting partial content returned for libs.js, and reloading the page often enough would eventually get everything downloaded.

If anyone else has this happen, I had to make the following change to my nginx.conf:

proxy\_buffering off;
