Add-ons menu does not appear

Good morning, I would like to know how to place the add-ons menu in my taiga (this menu does not appear, it is not visible), to integrate it with Slack I have version 6.7.0 of taiga community hosted on my PC. Thank you in advance.

https://docs.taiga.io/integrations-slack.html#_configure_slack
Captura desde 2024-01-30 10-24-50

Extra info

HTTP_HOST
http://localhost:9000/
HTTP_USER_AGENT
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:122.0) Gecko/20100101 Firefox/122.0

Hi @aescalona

Can you paste the content of the url http://localhost:9000/conf.json?

Best regards

{
“api”: “http://192.168.40.156:9000/api/v1/”,
“eventsUrl”: “ws://192.168.40.156:9000/events”,
“baseHref”: “/”,
“eventsMaxMissedHeartbeats”: 5,
“eventsHeartbeatIntervalTime”: 60000,
“eventsReconnectTryInterval”: 10000,
“debug”: false,
“debugInfo”: false,
“defaultLanguage”: “en”,
“themes”: [“taiga”],
“defaultTheme”: “taiga”,
“defaultLoginEnabled”: true,
“publicRegisterEnabled”: false,
“feedbackEnabled”: true,
“supportUrl”: “https://community.taiga.io/”,
“privacyPolicyUrl”: null,
“termsOfServiceUrl”: null,
“maxUploadFileSize”: null,
“contribPlugins”: ,
“gitHubClientId”: “”,
“gitLabClientId”: “”,
“gitLabUrl”: “”,
“tagManager”: { “accountId”: null },
“tribeHost”: null,
“enableAsanaImporter”: false,
“enableGithubImporter”: false,
“enableJiraImporter”: false,
“enableTrelloImporter”: false,
“gravatar”: false,
“rtlLanguages”: [“fa”]
}

Accept-Ranges bytes
Connection keep-alive
Content-Length 961
Content-Type application/json
Date Tue, 30 Jan 2024 18:53:29 GMT
ETag 65b7aa10-3c1
Last-Modified Mon, 29 Jan 2024 13:37:20 GMT
Server nginx/1.23.4
Accept text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,/;q=0.8
Accept-Encoding gzip, deflate, br
Accept-Language es-ES,es;q=0.8,en-US;q=0.5,en;q=0.3
Connection keep-alive
DNT 1
Host localhost:9000
Sec-Fetch-Dest document
Sec-Fetch-Mode navigate
Sec-Fetch-Site cross-site
Sec-Fetch-User ?1
Upgrade-Insecure-Requests 1
User-Agent Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:122.0) Gecko/20100101 Firefox/122.0

Here is what was requested, thank you very much.

As you can see, contribPlugins is empty so the Slack plugin is not enabled. How do you setup the plugin? As you can see in 30min setup, in docker-compose.yml:

Slack integration

Enable Slack integration in your Taiga instance. This feature is disabled by default.

Note
Be careful with the upper and lower case in these settiings. We will use ‘True’ for > the backend and ‘true’ for the frontend (this is not a typo, otherwise it won’t work).

Add to &default-back-environment environments

ENABLE_SLACK: "True"

Add to taiga-front service environments

ENABLE_SLACK: "true"

Then restart the docker-compose and then the new changes will take effect.

I hope this can help

1 Like