Question about database setup in the 30 guide

In the 30 minutes guide (wow 30 minutes) you specify using creds for connecting to database.

I do not see anywhere if you should create a database server or if Taiga docker setup does that for you?

Will just give it a shot and see what happens.

FYI. When I setup systems I tend to keep a log of questions and remarks. That will be this thread.

In the docker-compoose.yml files you can see all the services that Taiga needs. There is one database, of course:

# (...)

    image: postgres:12.3
      POSTGRES_DB: "taiga"
      test: ["CMD-SHELL", "pg_isready -U ${POSTGRES_USER}"]
      interval: 2s
      timeout: 15s
      retries: 5
      start_period: 3s
      - taiga-db-data:/var/lib/postgresql/data
      - taiga

# (...)

One recommendation, since it does not expose any ports to the outside, you do not need to modify the default settings (for POSTGRES_* and RABBITMQ_*) since they are sufficiently secure.

Best regards

Not interested in the yml. Not using composer directly…

If anything I use Portainer and could use the yml for a stack, which somehow would be using composer, but not really versed in that.

Of course there is a database, but it is not obvious that you need to install it.

I can read code somewhat, but imagine me doing it ONLY in the Portainer interface and want to have every step under control.

  • Database setup
  • Application setup
  • Other dependencies ? Setup…

You guide is not very explicit in regards to the database part, as far as I have experienced so far

The 30 minutes setup guide is just for a quick setup so If you want a more detailed guide, maybe you can check this other link Install Taiga in Production

A lot more interesting and pedagogical from a quick peek

The docs site seems broken though… wasn’t sure it was updated…

Left menu is not showing properly.

… and I removed the solved checkmark. I am the one to check something as solved. Not you.

Oh, sorry. Maybe it could be your browser, or some plugin/extension installed??

This is how I see the documentation pages with firefox

And with chrome

On the other hand, I have marked it as resolved because my previous message answered your question. We prefer to answer one question per topic so that it is easier for the community to consult. At least in the Troubleshoting category. But of course feel free to uncheck it if you think it hasn’t been answered yet.

I tested browsing with Vivaldi and Edge, both Chromebased browsers. It seems it only shows on Vivaldi, which is strange, but then, not any issue on your side from what I conclude.

I understand you need to sort questions somehow, but using “Solution” in a thread where the original author do not consider there is yet a solution is just the wrong approach. As a community manager with many years of experience from different forum platforms and moderation approaches, in my opinion, it really sends the wrong signal. Had it been a check mark for “Answered” it would be different.

But that is what you get for using Discourse, which is kinda crappy as Forum software. Never mind, I will refocus on the task at hand, please forgive me diverging a bit.

I will be installing Taiga in my SoHo SuperMicro servers, either using CLI or Portainer, I will have to check with those guys if they can help me with the stack or just go with command in Ubuntu Server… copy-pasting yml code is often too easy, and do not always grants a thorough understanding of what you are actually doing. Again, IMO.


Nice start…

No errors so far.

Many volumes

Perhaps not ideal:

serveradmin@ubsvr1:~/taiga-docker$ ./ createsuperuser
+ exec docker compose -f docker-compose.yml -f docker-compose-inits.yml run --rm taiga-manage createsuperuser
WARN[0000] Found orphan containers ([taiga-docker-penpot-frontend-1 taiga-docker-penpot-backend-1 taiga-docker-penpot-redis-1 taiga-docker-penpot-postgres-1 taiga-docker-penpot-exporter-1]) for this project. If you removed or renamed this service in your compose file, you can run this command with the --remove-orphans flag to clean it up.




any log I can look at somewhere? Checking docker container logs, but with 14 containers created is a bit of a hassle…

Can’t find any real errors in those logs, seems several http ports are used, not sure what they do, but no obvious conn errors that I can see, database is running, .env seems to have some correct info, but I am not certain about a couple of things.
This is running in Portainer/Docker on an Ubuntu Server in my SoHo with the IP . No proxy or anything like that involved.