Something happened and the Taiga has captured the error to be able to work on it

Hitting the above error after following the instructions on the repo.


Hi @manoj_m

Could you give me more details please?


I used the instructions from: GitHub - kaleidos-ventures/taiga-docker

all containers are running, any specific docker logs you want to look at?

I received the same error when I stood up an nginx proxy in front of the docker pieces. Everything worked fine when I was using ssh to tunnel into port 9000. Hope there is an easy solution.

1 Like

can you list the steps?

following works when run from my laptop: ssh -NL 9000:localhost:9000 remote-host

It’d be good if some can provide a reason why this is the case.

Hi @manoj_m and @greybear

In order to help you, we need:

  • check the logs docker logs -f to see if there is more information.
  • your docker-compose.yml (redacted without sensitive data)
  • your nginx settings (if you use it)
  • the result of docker-compose ps
  • before launching Taiga , check that you don’t have anything on port 9000.


I’m getting the same error and collected the info suggested.

  1. logs did not have much. Frontend container log only shows the http get attempt like: - - [17/Feb/2023:13:33:34 +0000] “GET /conf.json HTTP/1.0” 304 0 “http://docker-pr-app-a:9000/discover” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36” “-”, but no error. The backend container log shows a little more, but the only error entry is: [2023-02-17 13:26:27,135: ERROR/MainProcess] consumer: Cannot connect to amqp://taiga:**@taiga-async-rabbitmq:5672/taiga: [Errno 111] Connection refused.
  2. The docker-compose used was the default of the project, no edits made
  3. I don’t use nginx on my own. Only started taiga by running ./
  4. The result of docker-compose ps is:
    -bash-4.2$ docker-compose ps | grep taiga
    taigadocker_taiga-async-rabbitmq_1 rabbi … Up 15671/tcp, 15672/tcp, 15691/tcp,
    taigadocker_taiga-async_1 /taiga-back/docker/async_e … Up 8000/tcp
    taigadocker_taiga-back_1 ./docker/ Up 8000/tcp
    taigadocker_taiga-db_1 postgres Up 5432/tcp
    taigadocker_taiga-events-rabbitmq_1 rabbi … Up 15671/tcp, 15672/tcp, 15691/tcp,
    taigadocker_taiga-events_1 ./docker/ Up 8888/tcp
    taigadocker_taiga-front_1 / ngin … Up 80/tcp
    taigadocker_taiga-gateway_1 / ngin … Up>80/tcp
    taigadocker_taiga-protected_1 ./docker/ Up 8003/tcp
  5. Before running taiga, there’s nothing on port 9000.

Please, help…

Hi, @Mauricio_Rodrigues_d

Are you sure you haven’t changed anything?

If I download the repo, I start the services and access to http://localhost:9000 with my browser y can see the discover page.

And I see http://localhost:9000/ in my logs and not “http://docker-pr-app-a:9000

taiga-docker-taiga-front-1  | - - [20/Feb/2023:20:20:29 +0000] "GET /conf.json HTTP/1.0" 200 950 "http://localhost:9000/" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/110.0" "-"