Bug/Issue: No WYSIWYG input field when When you use a language other than English in setups under subpath

It seems like the comment function does only work if you use a certain language. When I choose English as language in my account settings, I can add comments to user stories but as soon as I change my language to German, I can no longer see the input field. There seem to be more languages affected by this issue, since I have tried to reproduce the issue with Spanish and there is no comment field as well.

Hi @mbr_cefak

I have tried it with different languages and for me is working properly, both in the SaaS version (tree.taiga.io) and in the on-premise version I have set up in my pc.

Are you using taiga SaaS or en-premise? What Taiga version are you using? With what browser? If you use an on-premise instance, have you installed it from source code or using the docker images?

Best regards

Have you tried accessing the platform using different web browsers or devices to see if the issue persists regardless of the language settings?

Sorry for the really late reply.
@david.barragan I am using taiga on-premise and did install it with docker.
@RoseAnjelia I have tried firefox and edge as browsers, but none of them shows me the comment field when using german language.
My taiga version is 6.7.1 if that helps.

I have try with the version 6.7.1 and is working for my, can you send us a screenshot?

Here a screenshot of my taiga with english language and one with german language. As you can see, the “Type a new comment here” section is missing for me when using german language.



I am so sorry but I have no idea what could be wrong with your taiga instance. I force my docker compose to use the 6.7.1 version and I can see the input

Try to update to the latest version (6.7.7) to see if the error persists.

Even in Spanish I can see the input.

I have found an error that might be related to the issue.

When I open the browser console, I receive this error:
Loading failed for the < script > with source “http://myIp/v-1695217671916/ckeditor-translations/de.js”.
The reason it fails to load the resource, is that taiga runs under “http://myIp/taiga” instead of just “http://myIp/”. When I add the ‘/taiga’, I can access the resource.
But how can i configure taiga, so that it uses the correct path?

Well, this is a bug. We will try to resolve it and include it in a future version.

Thanks for your report.