Forgot password not working

Hi there,
one of our users has just tried to reset their password. After a while, an error appears, that the user might not be registered. I’ve tried to reset the password by myself and I get the same error message even though my account is definitely registered. When I open the browser console, I repeatedly receive these two errors:
“Firefox can’t establish a connection to the server at wss://” and
“WebSocket error: [object Event]” - “GET

When I click on “Reset Password”, I receive the error message “POST
[HTTP/1.1 500 Internal Server Error 10287ms]”

Hi there!

Firstly, the web socket connection seems to be wss, so you may want to change it to ws if you are not using certificates.

In any case, this error should have nothing to do with your user resetting the password.

Could you share the nginx error logs for the API component?

Best regards!

Hi Charlie,

thank you for your response.
In my .env-file, I have now changed wss to ws and I receive the same error except now it says ws instead of wss in the error message.

In the error log, I get this error whenever I try to reset the password:
“AH01276: Cannot serve directory /var/www/: No matching DirectoryIndex (index.html,index.cgi,,index.php,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive”

How did you install Taiga?

Did you use this guide with docker? From source code?

Can you share your nginx configuration?

I did install Taiga by following the docker guide. The only difference is that I am using Apache instead of Nginx. My Apache config looks like this:

<VirtualHost *:80>
        DocumentRoot /var/www/
        <Directory /var/www/>
                Options +FollowSymLinks -Indexes
                AllowOverride All
                Require all granted

        ProxyPass /taiga http://localhost:9000/
        ProxyPassReverse /taiga http://localhost:9000/

        LogLevel warn
        ErrorLog /var/log/apache2/error.log
        CustomLog /var/log/apache2/access.log combined


I’m not familiar at all with Apache, perhaps someone else can be of help here.

Is that your entire Apache config? Because, compared to what it would be the nginx one, it seems not to have config for the API, events, etc.