New Install Setup.

Hello, I have setup a new Ubuntu v 20.4.6 server to host the Docker.
Docker Engine installed v 24.0.5
cloned git repo and tried running ./
This returned:

  • exec docker compose -f docker-compose.yml -f docker-compose.penpot.yml up -d
    unknown shorthand flag: ‘f’ in -f

Not sure what I am supposed to do with this since it is all fresh install and dedicated to purpose.
Should I stark hacking at it and remove the flag from the script? Should I reduce the version level of my OS or Docker Engine? Install from binary?

Thanks for assistance.

Well I solved part of it. I had to install docker-compose.
sudo apt install docker-compose
Then I had to edit the script changing 'exec docker compose -f ’ to 'exec docker-compose -f ’
On my system at least it required the hyphenated name for docker-compose.

I am still getting errors that I am not sure how to deal with.

RROR: The Compose file ‘./docker-compose.yml’ is invalid because:
services.taiga-async.depends_on contains an invalid type, it should be an array
services.taiga-back.depends_on contains an invalid type, it should be an array
services.taiga-events.depends_on contains an invalid type, it should be an array

I was able to get the script ./ to run by editing docker-compose.yml and comment-out all of the depends_on due to fact that I am seeing that Docker appears to be removing that feature.
This results in the launch_all script running but when opening the page http://myserver.mydomain.local:9000 I am greeted with a blank page. I do load the favicon though, yippy!
I can “view source” and see that it is loading something but whatever is supposed render the page isn’t functioning.

I guess I can try skipping Docker and install from scratch…

I hope someone has an idea seeing docker is the “preferred method”.

@daniel.herrero would you have any suggestion?

Well, I made some progress. The git repo and documentation needs to be updated for current versions. I had to modify the .env for it to properly launch without error.
According to Docker documentation, you must now use docker-compose not ‘docker compose’ and also it does not allow for conditions with ‘depends_on’. You have to pass conditions when you call docker-compose.

I changed launch-all script:

 #exec docker compose docker-compose.yml docker-compose.penpot.yml up -d $@


exec docker-compose -f docker-compose.yml -f docker-compose.penpot.yml up -d $@

I also changed the docker-compose.yml
Everywhere it calls depends_on I changed

       condition: service_healthy
       condition: service_started
        condition: service_started


      - taiga-db
      - taiga-events-rabbitmq
      - taiga-async-rabbitmq

It now starts but I am still getting blank page.

Is postgres and base db included in the docker or do I need to install and set up? It doesn’t mention it in instructions.
If I check the browser console I see this error:
Uncaught (in promise) SyntaxError: Expected ‘,’ or ‘}’ after property value in JSON at position 41
Promise.then (async)

I am not seeing where to find logs for this to see what is or isn’t working.

I found that I can see logs with

docker-compose logs

I can then use grep to filter those but I am not seeing what is the issue with it serving a blank page.

I removed it all and started over using the command:

docker-compose -f docker-compose.yml -f docker-compose.penpot.yml down --rmi all -v

Then I re-ran:

sudo git clone

and then:

sudo ./

It rebuilt it all and looking at logs seems okay but still blank page. How is this docker considered stable?

Hi @jcain,

I have a Linux Mint with an “Ubuntu 22.04”, and have reverted my Docker Desktop to a Docker Engine 24.0.6 and a Docker Compose v2.16.0 .

With your environment I can’t replicate the unknown shorthand flag: ‘f’ in -f error. Everything starts up correctly.

What docker compose plugin version do you have?

$ docker compose version

I strongly recomend to uninstall every docker-related package (specially docker-compose) and re-install Docker Engine following their official doc.

I think docker compose version 3 should support “depends_on” the same as version 2 does, but I’ve not check it. Let’s try first if a clean installation do the trick.

@daniel.herrero Thanks for the input.
I started off following Taiga 30min Setup and also found Install Taiga in Production and they both just state a base requirement as “docker**: version >= 19.03.0+”. I have Docker Engine installed v 24.0.5. If I issue command ‘docker-compose version’ I get the following:
docker-compose version 1.25.0, build unknown
docker-py version: 4.1.0
CPython version: 3.8.10

When I installed I just used the repo default from Ubuntu:

sudo apt install docker

It was after trying to install that I found I had to separately install compose. I found my only choice was docker-compose and I installed with:

sudo apt install docker-compose

I can remove it all and install Docker from source rather than Ubuntu repo but that should probably be put into the documentation.

Since I have gotten past all the above errors at this point, I am not very hopeful that it will fix my issues with the blank page and json error reported by my browser (I’ve tried Chrome and Firefox so it’s not the browser).

I will try the fresh Docker install and let you know.
Thanks again.

  • J

@daniel.herrero installing Docker with the instruction from Docker rather than Ubuntu base repository corrected the issues.
I am now getting a good page and able to log in.
I guess I should have followed exactly the instruction " If you don’t have docker installed, please follow installation instructions from" as posted in Taiga 30min Setup

Thank you for assisting me.

Not sure how to modify subject to show this topic as solved. No edit on top post.

Hi @jcain,

I’m glad you finally achieved to log in, well done! :clap:

To mark a topic solved, you just have to click on checkpoint of the reply that solves the problem, in its bottom part (first icon previous to the hear/like symbol). If you find any trouble I can do it for you.


And thank you for the support you offer to other users out there! :wink:

I can open a new thread if necessary, but I’m having the exact same problem – a blank page, but the favicon and the page source indicate that Taiga is serving successfully over my reverse proxy, yada yada.

I’ve applied all of the debugging steps from above, including the changes to the depends_on sections of docker-compose.yml. Worth noting, I’m having to use the Advanced Configuration from the installation guide. However, checking docker compose logs shows me that it is successfully connecting to PostgreSQL, RabbitMQ, etc. In fact, there aren’t even any error messages anymore.

I also installed the latest stable release of Docker two days ago according to the official Docker installation instructions mentioned above, so I have Docker Compose version v2.21.0. Beyond that, I’m running Ubuntu 22.04.

And yet, blank page with source code from Taiga when accessing either directly or through the proxy.

What else am I missing?

@CodeMouse92 I can’t tell you what you are missing but my problems resolved when I followed the instruction guide “EXACTLY” without making any assumption, which I had previously done by installing from Ubuntu apt repo rather than manually downloading and installing as mentioned in the guide(s).