Taiga in AWS EC2 Instance (no docker compose, no -f/-d flag)

Hello! I’ve been following the guide, and I did manage to get Taiga setup in a local dev Ubuntu VM, but when trying to get this into my AWS EC2 instance (Amazon Linux 2023), I run into some issues.

The first seems to be install-all.sh or launch-taiga.sh scripts.

The Amazon Linux 2023 EC2 instance is installing Docker 25.x.x.

The scripts that worked fine for Ubuntu don’t seem to work in the AWs Amazon Linux environment. The flags -f and -d do not seem to be supported.

bash ./launch-taiga.sh
+ exec docker compose -f docker-compose.yml up -d
unknown shorthand flag: 'f' in -f

So I tried to launch what the script is going for, removing the -f and -d flags…but now I’m left with:

exec docker compose docker-compose.yml up
docker: 'compose' is not a docker command.
See 'docker --help'

Everything was spin up and built yesterday, and may be too new for this setup? Is there a specific version of Docker that is supported better in AWS Linux 2023? I’m not sure how to navigate and configure the AWS Linux 2023 at a high level yet, but it seemed to be a Free Tier solution where Ubuntu / Debian may not have been.

So I am wondering if anyone here has recently setup Taiga in AWS EC2 recently on the Amazon Linux 2023 version of Linux?

I’m mostly configured already, with copies of my configurations, so I can remove taiga-docker completely and start over if necessary.


Hi there!

docker compose was kind of recently integrated into the main docker command. I’d recommend you try to either install docker following the instructions on the docker website, or try launching it like so docker-compose -f docker-compose.yml up -d. Notice the dash in the command.

You may also need to specifically install docker-compose.

Best regards!

I’ve decided to go this path, and start it with getting rid of AWS Linux 2023 for Ubuntu, and your process here worked excellent there. Thanks a ton.

1 Like