Error importing Taiga Project

We’re trying to migrate a project to our client Taiga instance.
Both Taiga versions - ours and our client’s - are the same.
We exported the project from our instance and generated the json as expected; however, when we try to import it into the client’s instance, we get this error message:

[error] 58#58: *30850 client intended to send too large body: 91355133 bytes, client:, server:, request: “POST /api/v1/importer/load_dump HTTP/1.1”, host: “”, referrer: “Taiga

Any tips as to what’s going on and how to solve the problem?

Hi @Bruno_Souza

This error usually happens because the file you are trying to upload to taiga is too large. It is not an error message thrown by taiga, the limitation comes from the web server (nginx, apache or whatever, It depends on your setup).

There are two options:

  1. use the manage command if you have access to the server to import the project directly from the terminal:

    ./ load_dump <filename.json> <new_owner_email_address>

    (or ./ for installation from source code)

  2. change your web server settings to allow sending requests with a large body**. If you are using docker setup and there is no web server in front of the taiga gateway, increase the number of client_max_body_size at taiga-gateway/taiga.conf file (from 100M to 300M or whatever)

I hope this can help

Best regards

Thanks, I’ll try it and give you some feedback if the problem persists.