I cannot login after install Taiga and edit docker compos

After install Taiga with docker
I got this error

Hi @Muhannad_Mekhezen and welcome to the community!

That screenshot doesn’t neccesarily means you’re facing an error. It can be a simple mismatch of user login/password according to the users in the database.

I guess you’ve followed the docker installation, so you have the option to create another superuser with ./taiga-manage.sh createsuperuser and try to log in again.

You also have the option to click in “Forgot it”, in your login screenshot, and enter a known email to reset the old user’s password. You should receive an email if you’ve set up EMAIL_BACKEND=smtp, or review the email directly in the console with $ docker logs taiga-docker-taiga-back-1if you’ve set up EMAIL_BACKEND=console in the .env file.

Last option is to allow new users to register by adding the variables PUBLIC_REGISTER_ENABLED to both taiga-front and taiga-back services.

    image: taigaio/taiga-front:latest
      # ...your customizations go here

We hope it serves!

I already create user by this command

./taiga-manage.sh createsuperuser
also when I add this inside the file and try to create a new account I cannot save it

    image: taigaio/taiga-front:latest
      # ...your customizations go here

Hi @Muhannad_Mekhezen

I was suggesting you to create a second superuser (execute the command again) and try to log in with her. This way we discard it’s not a bad-written password.

Sorry if I mislead you with my code snippet, as it’s not a complete example. You just have to add the two lines preserving the rest of your already defined variables:

  • Add to &default-back-environment the new line PUBLIC_REGISTER_ENABLED: "True"
  • Add to taiga-front service environments the new line PUBLIC_REGISTER_ENABLED: "true"

Note: Please, mind the two lines are different (“True” vs “true”)

Now you should be able to create new users by clicking in the proper link.

same issue also I cannot create a new user

@Muhannad_Mekhezen Are you using sudo when you edit the .env file?


What info do you have in the “Network” tab from the browser’s DevTool (press F12) while trying to log in with the superuser? We’re interested in the full request to authenticate the user in taiga-back: https://api.taiga.io/api/v1/auth

Another log it would be nice to have is the error while you’re creating the superuser in the CLI.

Without further data the only evident error is the entered password doesn’t match the password in the database for that user.

Thanks in advance

use sudo and root account is enabled

I have the same issue, I have tried to add the lines to allow creating new users but it doesn’t work.

I already created another superadmin but in the application it still tells me that it is incorrect or that it does not exist.

Now I have used F12 in network and it gives me error 405, what is the cause and how can I solve it?

Hi @mobsternation,

In a default installation it’s very easy to enable users to sign up. Simply edit your docker-compose.yml and:

  1. Add to &default-back-environment service the variable:


  1. Add to taiga-front service the variable:


  1. Restart the app with docker compose up

The 405 Not allowed status you’re receiving may reflect a problem in your proxy.

  • Do you have a proxy (nginx for instance) redirecting the requests in front of your Taiga installation?
  • Have you change anything in the config files (.env or docker-compose.yml) that may affect the default taiga-gateway service?



I hope you are well.

I have resolved it; I needed to install and configure RabbitMQ and Redis.

Great news, thank you for posting your solution! I hope it also serves to @Muhannad_Mekhezen.

By default it’s indeed installed as separated services (taiga-async and taiga-async-rabbitmq) to deal with the email async tasks, between others.

When nothing’s changed, the registration emails tasks will be processed and rendered in the taiga-back logs, and its there where you can get the validation links to finally activate the users.

I temporarily marked yours as the solution to fix this problem.